Import & Export

Export SERVER | DATA CENTER CLOUD

You can export your diagram as PNG, SVG and XML (.dmn) file. This can be done in different ways:

  • in page view via the export buttons above the diagram in the top right right corner (XML, PNG)

  • in diagram editor and presentation mode:

    1. via the buttons in toolbar (XML/PNG)

    2. in the navbar via "File"→ "Export" (XML, PNG and SVG)

 

|Since 2.0.0-ENTERPRISE|

Furthermore, the table representation of the diagram can be exported as a CSV file via "File" → "Export" CSV while in table mode.


Import

Local Files SERVER | DATA CENTER CLOUD

There are two different ways to import diagrams.
You can import standard-compliant .dmn files directly from your local file system. To import .dmn file in diagram editor:

  • go to "File" → "Import from file"

  • or drag and drop the file directly onto the diagram editor canvas

 

 

 

Existing Diagrams in Confluence SERVER | DATA CENTER CLOUD

|Since 2.0.0-ENTERPRISE|

Alternatively, diagrams from other Confluence pages can also be imported via "File"→ "Import from Confluence page". In this case you can choose whether you want to import all versions or only the latest one of the diagram using the Carry Version History toggle. Note that older versions of the diagram into which you are importing are not lost but still accessible in the version management and dropdown after the import.

 

Note that diagram versions imported from another Confluence page are not directly published on the Confluence page, even if you entered the diagram editor from the Confluence page view. You can change this by clicking "Publish this version now" in the message box showing up directly after the import. For more information on how versions are published on the Confluence page, please refer to the section https://viadee-modeler-demo.atlassian.net/wiki/spaces/DMED/pages/685178932 of this manual.

 

From GitLab SERVER | DATA CENTER CLOUD and Bitbucket SERVER | DATA CENTER

|Since 2.0.0-ENTERPRISE|

DMN diagrams can also be imported from your Version Control System (VCS), currently supported are GitLab or Bitbucket. This way, you can always pull in the latest revision that lies in your VCS and keep on modeling straight away in Confluence - no need to switch tools!

To import a diagram from GitLab or Bitbucket, you need to perform these 3 steps (steps 1 & 2 only need to be done once to set up the VCS connection):

  1. Ask your Confluence administrator to establish a connection between Confluence and GitLab or Bitbucket resp. in the app configuration of the DMN Modeler Enterprise. While this is not yet done, you see a message like this when opening the Import from VCS dialog. An article for admins how to establish a connection can be found in this manual in "Features for Confluence Admins" 

2. After the global configuration of the VCS connection, you will be asked to authenticate your GitLab account once: After that you will be able to use your own GitLab account to load .dmn files, and thus will only see projects and files you have the right permissions for.

 

3. Finally, you are able to import your diagram from your Version Control System: In the DMN Editor go to "File" >"Import from VCS", and choose Gitlab or Bitbucket on the left tabbar. Now you can search for a project, choose a git branch or tag and select a .dmn file from there. To be certain about the DMN diagram you are going to import, you can load a preview of the selected diagram.

IMPORTANT: The diagram will be copied only once from GitLab or Bitbucket to Confluence. If you make changes in Confluence, it will not be synchronized back to the VCS. Likewise, changes and new versions from your VCS are not automatically copied to Confluence.

Optional: It might happen that you import the same diagram from the same source multiple times, or even in a regular manner. For these cases, you can save your search/configuration from the Import from VCS dialog as diagram settings. If you do so, these settings are suggested as a preselection the next time you come to Import from VCS. However, they can still be changed before importing the diagram. They are only meant to save you time when you are often using the same configuration.

The default GitLab and Bitbucket sources can also be managed in the Diagram Settings ("Edit" → "Settings")


Upload to GitLab SERVER | DATA CENTER CLOUD

|Since 2.1.0-ENTERPRISE|

You may also want to export your DMN diagram to a remote GitLab repository. A prerequisite is that the DMN Modeler Enterprise is connected to GitLab.

To open the export dialog, press File → Push diagram to VCS.

The upcoming dialog is very similar to the “Import from VCS” dialog. Simply select your GitLab project, select a branch, and an existing file. If you want to create a new file, select “As new File” and enter the file path, ending with the file’s name.

Remember that for each diagram, it is possible to specify a default GitLab project/branch/file via the diagram settings.

After pressing “Push”, the following steps are taken automatically:

  • A new, temporary GitLab branch named <selected branch>-DMN-model-update is created (if it does not exist)

  • The changes are pushed to this temporary branch

  • A Merge Request is created to merge the temporary branch in the one that was actually selected (develop in the example on the right).

  • If the Merge Request is acceptable, it is automatically accepted, and the temporary branch is deleted.

  • If the Merge Request is not automatically acceptable (due to running pipelines, or a merge conflict, …) a manual merge is required. In this case, you receive the following message that leads to the GitLab Merge Request.